What's new

Missed mouse clicks


Sony battery
This problem has me thoroughly confused. I built myself a PC about three and a half months ago and ever since I started using it, I've had problems with mouse clicks (both left and right) occasionally not registering. Sometimes for a second or two, the mouse just won't click, which is very annoying (and sometimes fatal during a game). It's the same mouse I had on my old PC and it worked fine there, and I tried another (new and perfectly working) mouse in my new PC and it had the same problem, so I don't think the problem is with the mouse itself. I've plugged the mouse into the PS2 and USB ports - same problem regardless of which interface I use. The problem also occurs in both Windows and Linux, so I doubt it's a software problem. No programs seem to be unresponsive and it's a dual-core CPU, so I doubt heavy CPU usage is causing the lapse. Any idea what the problem might be?

EDIT: It seems as though the lapses tend to happen more often when I haven't done any clicking for a couple minutes, but I don't know. Also, sometimes while I'm holding a mouse button down (to select or drag), it will suddenly release before I physically release the mouse button - also very annoying.
Last edited:


Sony battery
Yeah, I almost think the thing is cursed. :happy: I feel like I kind of eliminated any possible hardware or software problems. Perhaps, to find the real problem, I must enter the realm of... limboware! Well, I'll try the mouse on another USB port on the slim chance that both my PS2 port and a USB port are crummy. Still open to any suggestions though. :p


New member
you always have to try the mouse on a different computer, and a different mouse on the computer. If its your computer, it might be your motherboard.


Mouse is an HID

I recomend checking in Microsofts database. MS drivers can find most HID's but sometimes I've noticed win2K ignores button presses on USB based devices. (IE game pads) So I suggest running a USB test on said HID device.
HID = Human Interface Device.

Go to USB org to find said test programs :)



Simple try unplugging it for about 10 seconds, then plug it in again. That helps me with my wireless Office 8k mouse